Honda EM3500S Generator Idle Down Issue

Reply

  #1  
Old 11-30-10, 03:43 PM
Member
Thread Starter
Join Date: Nov 2010
Location: USA
Posts: 2
Honda EM3500S Generator Idle Down Issue

I have searched the threads here and haven't found an answer to my problem. I was given a Honda EM3500S generator from my brother-in-law and it has run fine up until this year. The issue is that when you run it and turn on the auto throttle it seems to hunt for idle. I did find that it was idling too low on full and only putting out about 116-117 VAC. I adjusted that out. New plug, drained and clean the petcock bowl. When you apply a load to it it comes up to speed and stays there. When you take off the load the auto throttle drops low and then tries to recover, RPMs and voltage bouncing up and down. Any thoughts? Thanks to all in advance for any help. This is a great forum and I have enjoyed reading the posts.
 
Sponsored Links
  #2  
Old 11-30-10, 05:31 PM
Member
Join Date: Jun 2006
Location: St. Louis
Posts: 2,365
The carb is probably getting a little varnished, before removing it and giving it a real cleaning, I would suggest adding some SeaFoam or Chevron Techron to the fuel and running it, they are both very good. Have a good one. Geo
 
  #3  
Old 12-01-10, 04:39 AM
Member
Thread Starter
Join Date: Nov 2010
Location: USA
Posts: 2
Thanks Geo! That is what I was thinking about trying that. I have used Seafoam on a few of my older motorcycles that don't get ridden much. I am almost certain that I did put Stabil in the generator but even that is only good for so long. I hate to take the carb off/apart as I never seem to get everything back together correctly. Digital cameras are great though for taking pictures before and during dismantle so that you can look to see how everything goes back. Thanks again.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes