Toro 521 snowblower model #38052

Reply

  #1  
Old 12-11-10, 11:13 AM
Member
Thread Starter
Join Date: Dec 2010
Location: USA
Posts: 2
Cant keep snowblower running...

I recently bought a used toro 521 snowblower, model 38052. It will start on first 1 or 2 pulls everytime and runs great for about a 1/2 hr or so, but then it will die when throttle is turned up... It will still start and run on idle everytime but will not run at operation speed again until cooled down. I have tried adjusting everything every way I can think of. What am I missing?
 

Last edited by johnny1121; 12-11-10 at 12:10 PM.
Sponsored Links
  #2  
Old 12-11-10, 01:38 PM
Member
Join Date: Jul 2006
Location: Central New Hampshire
Posts: 754
sounds like the carb main jet is clogged. The main jet is located on the bottom of the carb bowl. Before you remove it, you need to drain the gas tank as the gas will run out when you remove the main jet.
 
  #3  
Old 12-11-10, 01:53 PM
Member
Thread Starter
Join Date: Dec 2010
Location: USA
Posts: 2
Thanks, I'll give that a try, now that we're getting nailed with a foot of snow.. LOL!
 
  #4  
Old 12-11-10, 02:54 PM
Member
Join Date: Jun 2006
Location: St. Louis
Posts: 2,365
If it runs fine for 30 minutes I doubt if the main jet is clogged, sounds more like the fuel cap is not venting properly or the fuel line is collapsing, check the fuel line routing for kenks and try loosening the fuel cap when it starts to shutdown. Have a good one. Geo
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes