Stihl BR 340 Leaf Blower

Reply

  #1  
Old 02-27-11, 02:16 PM
Member
Thread Starter
Join Date: Mar 2008
Location: usa
Posts: 21
Stihl BR 340 Leaf Blower

I have a Stihl BR 340 Leaf Blower which starts on the first pull, but immediately after starting I have the play with the throttle for about a minute because it lacks power and sounds like it's about to stall out. After about a minute it will then go to full power and no other problems experienced. Any ideas on why this might be happening and suggestions on how to troubleshoot ? Thanks for the help.
 
Sponsored Links
  #2  
Old 02-27-11, 07:10 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
Sounds like the high speed mixture screw needs to be backed out a hair.
 
  #3  
Old 02-28-11, 06:17 AM
Member
Thread Starter
Join Date: Mar 2008
Location: usa
Posts: 21
Thanks for your reply. Honestly I am a novice and there are two screws to adjust and I don't wish to turn the wrong one for fear of making the problem even worse. Is it possible to tell which is the high speed mixture screw?
 
  #4  
Old 02-28-11, 09:11 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
Of the two screws side by side, the high speed screw is the one nearest the air filter. Back it out 1/8 turn or so and see how it does.
 
  #5  
Old 02-28-11, 05:03 PM
Member
Thread Starter
Join Date: Mar 2008
Location: usa
Posts: 21
Thank you so much. It's now purring like a kitten !
 
  #6  
Old 02-28-11, 07:01 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
Originally Posted by PJL1969 View Post
Thank you so much. It's now purring like a kitten !
Great! Glad to help!_________________
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes