Craftsman riding mower won't start

Reply

  #1  
Old 05-30-11, 09:44 AM
Member
Thread Starter
Join Date: May 2011
Location: USA
Posts: 1
Craftsman riding mower won't start

Have Craftsman model 91720512 6 speed, 42" cut, 14.5 Briggs & Stratton motor. Have replaced ignition switch, starter Solenoid. Was cutting grass yesterday, it was running fine and after running for about 1/2 hour, just dies like if you got off seat and safety switch killed it. Turn key, no click, no crank, obviously no start. It was late so called it a day, checked today and thought I found problem with a loose white crimp connector going to switch for clutch, it has a 4 pin block connector that plugs into clutch switch that clips into frame, 2 white wires, 2 black wires. Repaired connection, nothing! checked and replaces 30 AMP fuse, looked OK, checked battery voltage, fully charged 12.6 volts, checked wires for seat safety switch, they look OK What Next? Please Help Lawn is like a jungle!!! Suggestions to fix today???
 
Sponsored Links
  #2  
Old 05-30-11, 10:28 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
Are the battery connections clean and tight? Is there power to the ignition switch?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes