Which primer bulb for Tecumseh engine


  #1  
Old 06-03-11, 07:12 PM
B
Member
Thread Starter
Join Date: May 2011
Location: USA
Posts: 7
Received 0 Votes on 0 Posts
Which primer bulb for Tecumseh engine

I need a new primer bulb. The mice ate it.
The Tecumseh engine is on a Toro push mower from Home Depot.
I went to the repair shop with the model number. He said he needed the spec number. So he sold me 3 different bulbs. When I got home I called to give him the spec number and then he looked it up. Turns out he did not have any info on my engine. So I am stuck with 3 bulbs.
My Tecumseh engine model #LV195XA...Spec #362089E.
I have...
1) 1 dome shaped red bulb with no air hole in it.
2) 1 red bulb that has a "shoulder" and an air hole in it.
3) 1 black bulb with a "shoulder" and no air hole in it.

I think I need the one with a "shoulder" but I do not know if it needs to have an air hole or not. Can you help me?
 
  #2  
Old 06-03-11, 08:04 PM
A
Member
Join Date: Nov 2005
Location: USA
Posts: 491
Received 4 Votes on 4 Posts
You need part number 640351

AJ
 
  #3  
Old 06-03-11, 10:05 PM
B
Member
Thread Starter
Join Date: May 2011
Location: USA
Posts: 7
Received 0 Votes on 0 Posts
He sold me B171263, B171263 and 632047A. He said I could return what I do not use. They all look the right size. Can you tell me if 640351 has the air hole in it?
 
  #4  
Old 06-04-11, 08:20 AM
A
Member
Join Date: Nov 2005
Location: USA
Posts: 491
Received 4 Votes on 4 Posts
It is steped non vented but it needs a seal under it that comes with the primer. see picture



AJ
 
  #5  
Old 06-04-11, 11:15 AM
B
Member
Thread Starter
Join Date: May 2011
Location: USA
Posts: 7
Received 0 Votes on 0 Posts
The only one I have that is stepped and has no hole is black. I measured the retainer ring. Exactly this same size. I measured the base of the rubber. The new one is about 25/1000 smaller which I attribute to the old one being seated and squashed down by the retainer. It does not leak on the carb. When I push the primer I hear no squishy sound. I had to unsticky the float valve and put gas in the cylinder to start it. It has been sitting for 2 years so it was a little gummy. Anyway, it started. I will let it get cold again and try the primer and see if it makes a difference.
How do you tell it the primer is priming?
I did not know about the white plastic part and the spring under the primer. They fell out and miraculously I saw them land. I put them back in. They should be ok.
 
  #6  
Old 06-04-11, 12:23 PM
B
Member
Thread Starter
Join Date: May 2011
Location: USA
Posts: 7
Received 0 Votes on 0 Posts
I went out and started the mower. I then pushed the primer bulb. The mower sputtered. Is that an indication that the bulb is working?
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: