Replaced Karcher Pressure washer pump


  #1  
Old 07-14-11, 03:39 PM
T
Member
Thread Starter
Join Date: Jul 2011
Location: USA
Posts: 4
Received 0 Votes on 0 Posts
Replaced Karcher Pressure washer pump

I smelled rubber burning after I replaced the pump. What could be the problem?
 
  #2  
Old 07-14-11, 07:08 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 17,604
Received 54 Votes on 49 Posts
Knowing what you have might help, since there are a zillion different pump/engine configurations. What part is rubber? That might lead you in the right direction.
 
  #3  
Old 07-17-11, 06:51 AM
T
Member
Thread Starter
Join Date: Jul 2011
Location: USA
Posts: 4
Received 0 Votes on 0 Posts
Taking the pump apart again today.
Everything seemed to work during the initial start-up; except the burning smell from the pump area. I did notice a rubber seal on the bottom of the Honda engine around the vertical shaft. I did not notice any lubricating fluid escaping from the vertical shaft area when I removed old pump. Scratching my head as to why I saw smoke and smelled rubber burning.
 
  #4  
Old 07-17-11, 07:07 AM
T
Member
Thread Starter
Join Date: Jul 2011
Location: USA
Posts: 4
Received 0 Votes on 0 Posts
I apologize....removing the replacement pump from the engine would have been a better description.
 
  #5  
Old 07-18-11, 09:44 AM
T
Member
Thread Starter
Join Date: Jul 2011
Location: USA
Posts: 4
Received 0 Votes on 0 Posts
Replaced transmission /pump assembly; worked fine. Noticed smoke so I shut it down. Smoke smelled like rubber. Pushed/tilted pressure washer back to see underneath, oil poured out between engine and transmission area? Did not see a seal when old transmission/pump assembly was removed. Do not see how the oil is escaping from crankcase.
 
  #6  
Old 07-18-11, 04:37 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 17,604
Received 54 Votes on 49 Posts
We still don't know what you have. Without info only you can provide us with, we would be only making wild guesses.
 
  #7  
Old 09-11-11, 08:18 AM
RachelRoberts's Avatar
Member
Join Date: Sep 2011
Location: United States
Posts: 0
Received 0 Votes on 0 Posts
I also have a warranty claim on the lance connector with the patio plus (130.2 gerni)
and customer service was great, new parts arrived in Brisbane from Sydney within 48hrs
 

Last edited by Shadeladie; 09-11-11 at 11:07 AM. Reason: Link removed. Advertising not allowed.
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: