Briggs & Stratton 5HP engine with loose part in pull-start mechanism

Reply

  #1  
Old 09-04-11, 12:49 PM
Member
Thread Starter
Join Date: Sep 2011
Location: USA
Posts: 1
Briggs & Stratton 5HP engine with loose part in pull-start mechanism

We have a 30+ year old Poulan log splitter with a 5HP B&S replacement engine that has worked great for many years. The other day, I pulled the cord to start it and heard a sound like metal being thrown around. My husband took the pull-start cage apart and found a rectangular piece of metal inside (with a curve at the bottom of one side that looks like it had fallen off something, but he couldn't find the screw that had held it on or any indication of what it's purpose was. It has a hole for a screw and is relatively clean, in case that information is helpful. It's 4-1/4 inches wide, 1-7/8 inches high, has a bent section with a screw hole that is wider at one end than the other, and there are 2 small bar-like indentations in the left middle section, Does anyone know where to reattach it and if it serves a vital function? We live very far from the nearest place to get it fixed, and would really appreciate information that would allow us to fix it ourselves. Thank you.
 
Sponsored Links
  #2  
Old 09-04-11, 04:00 PM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,728
I thought the piece you described was one of the drive dogs that engage the flywheel until I reread your post and saw the dimension of it. I don't know what that thing is.
 

Last edited by marbobj; 09-04-11 at 04:35 PM.
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes