Poor running Honda es6500 generator


  #1  
Old 10-15-11, 08:55 PM
W
Member
Thread Starter
Join Date: Oct 2011
Location: usa
Posts: 1
Upvotes: 0
Received 0 Upvotes on 0 Posts
Poor running Honda es6500 generator

I've got a 10 year old HONDA ES6500 Gas generator. Up till now, its' been flawless. But, in the last week, it will no longer run unless the choke is partially pulled. Gas is good, Spark plugs have been replaced. Further, when running, the engine speed is constantly accelerating and decellerating. HELP! This is my primary back-up for my solar power.. Thanks....
 
  #2  
Old 10-15-11, 09:14 PM
R
Member
Join Date: Oct 2011
Location: USA
Posts: 3
Upvotes: 0
Received 0 Upvotes on 0 Posts
I picked up almost the same generator from a guy through craigslist yesterday. Mine is a EB6500, it didn't run at all. I went through the carb and found lots of old gas varnish built up. At the bottom of the carb there was also a solenoid that was stuck. I would first start by shutting off the gas, remove the solenoid and connect it to a 12v battery to see if the solenoid is still good....either polarity it doesn't matter, if it is good it will pop up when connected. I would then go through the carb and clean it thoroughly. I then put in clean gas, a little sea foam, and I was good to go. Good luck!!!
 
  #3  
Old 10-16-11, 12:11 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,026
Received 152 Upvotes on 139 Posts
Yep. you need to clean the carb.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: