Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Briggs and Stratton 375 bulb primer engine, won't start and kicks back.


Kaiser Bill's Avatar
Member

Join Date: Jan 2012
Posts: 3
Non-US

01-18-12, 07:55 PM   #1  
Briggs and Stratton 375 bulb primer engine, won't start and kicks back.

Engine has good spark, primer works well (have replaced diaphragm) after several pulls plug is wet. Removed flywheel and checked keyway, all well. Also starter pull kicks back viciously. Any advice would be much appreciated.

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,573
GA

01-18-12, 09:24 PM   #2  
Welcome to DIY!

What's it connected to? Horizontal shaft, vertical, model#? If the flywheel key is good, I will hazard a guess that this is a vertical shaft engine on a walk-behind and it probably has no blade on it. That's why it's kicking.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Kaiser Bill's Avatar
Member

Join Date: Jan 2012
Posts: 3
Non-US

01-18-12, 10:23 PM   #3  
Hi, it's a verticle shaft off a lawnmower. I have it bolted on a folding workbench and have removed the blade to sharpen. I've had the flywheel off and checked key, there's no play with flywheel.

 
Kaiser Bill's Avatar
Member

Join Date: Jan 2012
Posts: 3
Non-US

01-18-12, 11:15 PM   #4  
Cheese, you're fabulous....I have just bolted engine back on mower and re installed the blade and pulled cord 4 or 5 times and presto ! not only is there no kick back but the bloody thing started and runs good. It's now just after 8pm here so tomorrow I'll go over everything again. Again, thank you it's most appreciated.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,573
GA

01-19-12, 06:12 PM   #5  
No problem, glad I could help!


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread