7.5 B&S Intek not starting..

Reply

  #1  
Old 03-05-12, 01:38 PM
Member
Thread Starter
Join Date: Nov 2008
Location: USA
Posts: 20
7.5 B&S Intek not starting..

I have a 7.5 Briggs Intek engine that I used to upgrade my Ariens snowblower. Using it one day, it suddenly shut down and wouldn't restart. After checking the basics..ie spark and fuel, I checked compression, which was zero. I also noted that I was getting a good puff of air out the carb on each stroke. Next, I checked the valve timing. It seemed that they were opening when they should (intake opens at bdc and exh opens a tdc at the proper stroke). Then I pulled the head and took the valves out. I noticed that the valve guides are sitting at different positions for the intake and exhaust. Is this correct? Could it be the reason for my no start? The cylinder wall looks good, no scoring. Although there is some staining. The valves don't look bent although manually moving the valves, the intake sticks. Any other ideas? Thanks!


 
Sponsored Links
  #2  
Old 03-05-12, 11:38 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,639
Yes, you dropped a valve guide and it is holding the valve open. This is generally caused by heat. I'd look for a good used head on ebay or something like that, but you might have success pressing the guide back in and peening around it a bit to help hold it.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'