B&S 540CC 20hp engine on Craftsman lawn tractor sprays oil, backfires

Reply

  #1  
Old 03-06-12, 11:23 AM
Member
Thread Starter
Join Date: Mar 2012
Location: USA
Posts: 1
B&S 540CC 20hp engine on Craftsman lawn tractor sprays oil, backfires

My 4 year riding mower with Briggs 20hp engine began backfiring last year. Happens when weather is hot, not when it's cold. Am running it now in Feb-March to haul firewood in a cart with no problems as long as it's warmed up before receiving a load to pull. If I start off without running engine three or four minutes it stalls. In warm weather after I've run it for say 20 minutes occasionally it backfires with an incredible BANG and an enormous cloud of white smoke comes out of the exhaust. Thereafter, engine begins to lose power and stutter, sometimes stops. I let it sit and it starts up fine. I notice a great deal of oil seems to be sprayed out around the engine and the oil needs topping upevery time I run it. It seems to me the engine is not as powerful as it was three years ago and that the oil I need to add has gotten bigger. I carefully maintained this with regular oil, spark plug/fuel filter/oil filters etc. I'm not a tech person.
 
Sponsored Links
  #2  
Old 03-06-12, 04:35 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,820
To me it sounds a bit like you have both a dirty carburetor and a blown head gasket. A leakdown test, or head removal and visual inspection would tell about the head gasket condition.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes