Echo PB200 Blower will on start and run on 60% choke

Reply

  #1  
Old 04-09-12, 05:14 PM
Member
Thread Starter
Join Date: Apr 2012
Posts: 2
Echo PB200 Blower will on start and run on 60% choke

I have an Echo PB200 blower that will start but dies when the choke is opened. It will run with the choke about 60% closed. I have changed the plug and air filter and considering carburetor overhaul but wanted some input from the forum as to whether there could be something else I should consider.
 
Sponsored Links
  #2  
Old 04-09-12, 06:11 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,821
It's the carburetor. Try backing out the high speed screw a little and see if it improves. There should be 2 small screws side by side on the carb. The high speed one is the one closest to the air filter.
 
  #3  
Old 04-10-12, 08:52 AM
Member
Thread Starter
Join Date: Apr 2012
Posts: 2
The operator manual says "Every unit is run at the factory and the carburetor is set in compliance with emission regulations. This carburetor does not have acceleration and high speed adjustment needles." Yet there is a HI speed ajustment screw but it has a red plastic cover over it preventing adjustment. Can this plastic cover be removed without damaging the carburetor?
 
  #4  
Old 04-10-12, 09:43 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,821
Yes, it can be pulled off carefully. Sometimes a little trash or varnish gets caught at the needle of the screw and you have to turn it a little to get it to break loose and pass. You can often set it right back to the factory setting once it clears.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes