Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Echo PB200 Blower will on start and run on 60% choke


Awayne's Avatar
Member

Join Date: Apr 2012
Posts: 2
OK

04-09-12, 05:14 PM   #1  
Echo PB200 Blower will on start and run on 60% choke

I have an Echo PB200 blower that will start but dies when the choke is opened. It will run with the choke about 60% closed. I have changed the plug and air filter and considering carburetor overhaul but wanted some input from the forum as to whether there could be something else I should consider.

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

04-09-12, 06:11 PM   #2  
It's the carburetor. Try backing out the high speed screw a little and see if it improves. There should be 2 small screws side by side on the carb. The high speed one is the one closest to the air filter.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Awayne's Avatar
Member

Join Date: Apr 2012
Posts: 2
OK

04-10-12, 08:52 AM   #3  
The operator manual says "Every unit is run at the factory and the carburetor is set in compliance with emission regulations. This carburetor does not have acceleration and high speed adjustment needles." Yet there is a HI speed ajustment screw but it has a red plastic cover over it preventing adjustment. Can this plastic cover be removed without damaging the carburetor?

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

04-10-12, 09:43 AM   #4  
Yes, it can be pulled off carefully. Sometimes a little trash or varnish gets caught at the needle of the screw and you have to turn it a little to get it to break loose and pass. You can often set it right back to the factory setting once it clears.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread