Mantis Tiller

Reply

  #1  
Old 05-02-12, 11:38 AM
Member
Thread Starter
Join Date: Apr 2012
Posts: 5
Mantis Tiller

I have a Mantis Tiller and I can't get it started. I have changed the Spark Plug, Changed the air filter and checked the on/off switch Wiring. Does anyone have an Idea?
 
Sponsored Links
  #2  
Old 05-02-12, 11:46 AM
Member
Join Date: Dec 2009
Location: bond county illinois
Posts: 170
mantis tiller

Do you have spark at the plug? If so can you put a little gas in the carb and will it run?
 
  #3  
Old 05-02-12, 11:52 AM
Member
Thread Starter
Join Date: Apr 2012
Posts: 5
Yes Spark at the Plug and already tried the gas bit
 
  #4  
Old 05-02-12, 12:08 PM
Member
Join Date: Dec 2009
Location: bond county illinois
Posts: 170
mantis

Well, i think those are 2 cycle engines on them so the only thing left is compression. Is that an older model? 2 cycle engines should have at 125 lbs to run or at least that's what i've found in my experiences with them.I would check that also. Do you at least get a pop or anything with the gas trick?
 
  #5  
Old 05-02-12, 12:21 PM
Member
Thread Starter
Join Date: Apr 2012
Posts: 5
No pop at all, Do you maybe Think it may be a clogged gas filter inside the gas tank?
 
  #6  
Old 05-04-12, 06:43 AM
Member
Join Date: Dec 2009
Location: bond county illinois
Posts: 170
Sorry it took so long. It could be a clogged filter but putting gas in it should at least give you a pop or something. when you pull on the rope does it seem to have any kind of drag to it, like there is compression? Also look in the cylinder ( pull the plug out) and see if the piston is moving?
 
  #7  
Old 05-04-12, 05:46 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
Is the exhaust clogged? Is the spark plug wet? Does the engine have compression?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes