honda gcv160 mower,rpm problem


  #1  
Old 06-11-12, 06:31 AM
S
Member
Thread Starter
Join Date: May 2009
Location: United States of America
Posts: 38
Received 0 Votes on 0 Posts
honda gcv160 mower,rpm problem

I have a honda self propelled hrr2163tda mower with the gcv160 eng.This spring the rpm's started to rise and fall with the mower moving or not moving.At first I thought maybe the carb was plugged up so I removed it,soaked it in cleaner and reinstalled it with new gaskets.It ran better but the rpm problem was still there.Then after doing some research on line I replaced the spark plug ,again no improvement.I have found that if I force the govenor link to remain stationary that it will idle smooth.I have given the govenor link and springs a very close inspection and they all appear fine.I am certain I reattached it correctly to the carb when I removed it for cleaning.I feel like I've checked everything with no improvement but I must be missing something.Any ideas?
 
  #2  
Old 06-11-12, 08:26 AM
C
Member
Join Date: Nov 2001
Location: Taylors, SC
Posts: 9,483
Received 0 Votes on 0 Posts
Mine does that when the air filter needs cleaning.
 
  #3  
Old 06-11-12, 09:00 AM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 25,081
Received 867 Votes on 798 Posts
I would try cleaning carburetor again. This time disassembling it to better clean the internal passages & jets.

 
  #4  
Old 06-12-12, 05:39 AM
S
Member
Thread Starter
Join Date: May 2009
Location: United States of America
Posts: 38
Received 0 Votes on 0 Posts
Soaked the carb overnight in a parts washer.Its running fine now.Thank you
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: