Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Walbro carb for wildthing (poulan) Chain saw


MRI Vato's Avatar
Member

Join Date: Jun 2012
Posts: 3
AL

06-16-12, 05:48 PM   #1  
Walbro carb for wildthing (poulan) Chain saw

Anyone have this prob with carb?

I have replaced the acetone pump and gasket, and the regulator and gasket. Pretty sure that I have everything in the right order. I have checked the fuel lines 10 times but I can't get it to prime correctly. I did have the lined to the primer bulb backwards and could not push fuel into the carb (obviously) so then I switched them and now it creates a vacuume but fuel won't get into the bulb. Sometimes the bulb wont expand. Any ideas?

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

06-16-12, 07:52 PM   #2  
Sounds like the carb is clogged and needs cleaning.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
hopkinsr2's Avatar
Member

Join Date: Feb 2005
Posts: 1,561
Non-US

06-16-12, 07:54 PM   #3  
((acetone pump and gasket,,& regulator and gasket.)) Don't really know what you mean by this.. If the bulb sometimes won't expand, then I suspect the carb needs a good cleaning with a new kit installed

Roger

 
joeyr's Avatar
Member

Join Date: Jun 2012
Posts: 2
TN

06-30-12, 07:41 PM   #4  
sounds like you have the two gaskets switched the thin gasket goes next to the carb.Maybe that will help.

 
Search this Thread