Walbro carb for wildthing (poulan) Chain saw

Reply

  #1  
Old 06-16-12, 05:48 PM
Member
Thread Starter
Join Date: Jun 2012
Posts: 3
Walbro carb for wildthing (poulan) Chain saw

Anyone have this prob with carb?

I have replaced the acetone pump and gasket, and the regulator and gasket. Pretty sure that I have everything in the right order. I have checked the fuel lines 10 times but I can't get it to prime correctly. I did have the lined to the primer bulb backwards and could not push fuel into the carb (obviously) so then I switched them and now it creates a vacuume but fuel won't get into the bulb. Sometimes the bulb wont expand. Any ideas?
 
Sponsored Links
  #2  
Old 06-16-12, 07:52 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,815
Sounds like the carb is clogged and needs cleaning.
 
  #3  
Old 06-16-12, 07:54 PM
hopkinsr2's Avatar
Member
Join Date: Feb 2005
Location: canada
Posts: 1,561
((acetone pump and gasket,,& regulator and gasket.)) Don't really know what you mean by this.. If the bulb sometimes won't expand, then I suspect the carb needs a good cleaning with a new kit installed

Roger
 
  #4  
Old 06-30-12, 07:41 PM
Member
Join Date: Jun 2012
Posts: 2
sounds like you have the two gaskets switched the thin gasket goes next to the carb.Maybe that will help.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes