Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Troy Bilt 4 cycle weed eater won't prime


mlucas01's Avatar
Member

Join Date: Jun 2008
Posts: 10
OK

07-01-12, 02:43 PM   #1  
Troy Bilt 4 cycle weed eater won't prime

I have a Troy Bilt TB465SS 4 stroke weedeater and the only way to get it to prime is to turn it upside down! Bulb seems good but it just wont prime unless it is almost completely upside down. And after it starts it wont stay running after the fuel in the line is used up. It has full tank of fuel. I'm thinking maybe diaphram? Any suggestions would be appreciated.

 
Sponsored Links
mowerdude's Avatar
Member

Join Date: Oct 2011
Posts: 433
AR

07-01-12, 04:02 PM   #2  
Check ALL you fuel line connections and the inlets itself. Take carb apart and make sure gas will pass through screen also. I did one just last week and the fuel return port was plugged and the screen in the carb was plugged. Make sure also that the fuel pump diaphragm is not stuck. Good luck.

 
mlucas01's Avatar
Member

Join Date: Jun 2008
Posts: 10
OK

07-01-12, 04:40 PM   #3  
figured it out!

Got to thinking about it, wont prime unless its upside down (when the fuel is all the way to the top of tank!!). Fuel line was cracked at the top of tank. Guess I dint think about it hard enough until I typed it. Thanks for the ideas!

 
mowerdude's Avatar
Member

Join Date: Oct 2011
Posts: 433
AR

07-01-12, 08:27 PM   #4  
That will work,,,your welcome.

 
Search this Thread