Red Max HTZ 2401 Hedge Trimmer idles but cuts out when you rev engine

Reply

  #1  
Old 07-06-12, 11:11 AM
Member
Thread Starter
Join Date: Jul 2002
Location: Staten Island, New York
Posts: 182
Red Max HTZ 2401 Hedge Trimmer idles but cuts out when you rev engine

Red Max HTZ2401/CHTZ2401 2 cycle engine
Walbro WYA 67 746 Carb/throttle body

The engine will start and idle. I can slowly accelerate the throttle a bit, but when it starts to reach the speed needed for the clutch to kick in and start moving the blades - the engine dies right out.

I ran it with the air filter off and no sign of fuel leaking out of air intake. Disassembled the carb/throttle body and didn't see anything obvious. Would a weak or stretched diaphram cause this - should I get a carb rebuild kit? I put it all back together but still have same problem.

The machine is 5 or six years old and a lot of hours on it. I read that the mufflers tend to clog up - could this cause the cut out on acceleration?

I appreciate any advice.
 
Sponsored Links
  #2  
Old 07-06-12, 10:05 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,819
This sounds like a lean condition caused by a restriction in the carb. A cleaning will probably fix it up, but it may need a carb kit if not. A clogged muffler will cause high speed issues, but it doesn't kill the engine normally, it just keeps it from revving up.
 
  #3  
Old 07-17-12, 02:30 PM
Member
Thread Starter
Join Date: Jul 2002
Location: Staten Island, New York
Posts: 182
I thoroughly disassembled and cleaned the carb and blew it out with compressed air. Tried it twice. Same problem.

I contacted an online parts supplier who also offers repair & troubleshooting advice. I wanted to order the carb rebuild diaphragm & gasket kit but he advised replacing entire carb. He said this was an older model carb but that he had 2 new in stock that he would sell at a big discount.

I considered the price $68 plus $10 shipping for brand new in box Walbro including the filter, he said carb lists over $100, & rebuild kit around $30. Anyway I installed the new carb and filter and fuel line today and it runs great. Wanted to let ou know how I made out.
 
  #4  
Old 07-17-12, 02:46 PM
Member
Join Date: Oct 2011
Location: USA
Posts: 433
Dang that's HIGH,,,for kit and carb,,,,,,,He's really marking things up. Good to hear ya got it running.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes