Generac 10000exl

Reply

  #1  
Old 07-30-12, 01:20 PM
Member
Thread Starter
Join Date: Jul 2012
Posts: 1
Generac 10000exl

I have 1999 Generac 10000EXL generator (19hp & 10KW gen) and as I was replacing the battery I inadvertenly connected the battery back wards. Approximately 30-60 seconds after connecting it I noticed a small amount of smoke coming out of the control panel and quickly disconnected the batter. I opened the control panel and found the wires going to the starter switch were burnt so I replaced them, reconnected the battery correctly and started the engine. I left the control panel open so I could confirm the wires did not get hot again and noticed the battery charger rectifier (P/N: 65795) started to smoke and I turned off the generator. I just ordered another rectifier but would like to know if there is anything else I need to look at before I attempt to run this again once I replace the rectifier. The generator is Model# 9801-3. I have attached the owner's manual and pictures of the generator.
 
Attached Images       
Sponsored Links
  #2  
Old 07-30-12, 07:24 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
Well, since it started, apparently it didn't burn up the coils. It may have hurt the charging stator, but may not have. I'd put the regulator on it and go from there.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes