Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Engine cutting out - driving me nuts!


Lawse's Avatar
Member

Join Date: Jul 2009
Posts: 5

08-06-12, 03:16 AM   #1  
Engine cutting out - driving me nuts!

Hi there. I have a Toro Wheel Horse with a Kawasaki liquid-coold V-Twin OHD, FD620D.

The issue is engine will run for a random period (be it 5/15/40 minutes) before sputtering out. I generally cannot restart it immediately: by using choke (even though hot), it may cough and splutter but then dies out with eventually no response to ignition turning engine over (ie will not fire). I have to leave it for 20 minutes or so before I can restart it and off we go again... I have removed spark plugs (se well as replaced) and checked that there is a spark when engine dies, so does not seem electrical. Also, when there is oil around the outside of the top of the carb, I noticed today...

This has been going on for a couple of years, though is now worse. It is driving me nutso .

Anyone have any ideas? Thanks

 
Sponsored Links
butcho's Avatar
Member

Join Date: Dec 2009
Posts: 170
IL

08-06-12, 07:02 AM   #2  
I'm not familiar with that particular engine but it sounds to me like you have a
intake valve not seating properly when the engine gets hot. Pro's will be on soon to further this,i'm sure.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,574
GA

08-06-12, 05:30 PM   #3  
I have a good bit of experience with that engine. Check the fuel pump. It gets hot and stops pumping. I've seen this happen on several, and with the same symptoms.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Lawse's Avatar
Member

Join Date: Jul 2009
Posts: 5

08-07-12, 06:55 AM   #4  
thanks big cheese - unfortunately I had already done that (sorry, forgot to say) - any other ideas?

 
Search this Thread