snapper s31sst weed eater

Reply

  #1  
Old 08-23-12, 02:12 PM
Member
Thread Starter
Join Date: Aug 2012
Posts: 2
snapper s31sst weed eater

I have the weed eater above that is not working correctly, it worked fine last week but today it is not acting like it should pulling the rope. It feels like the exhaust valve isn't opening up! its hard to pull and jerks like the compression is not being expelled. pulling the spark plug out and it pulls nice and easy. Any ideas on the problem for this or is it time to get a new one??
thanks
 
Sponsored Links
  #2  
Old 08-24-12, 10:27 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,820
Well, that is a 2-stroke trimmer, so it doesn't have an exhaust valve. Normally when a 2-stroke gets hard to pull like high compression, it's because the engine is flooded with gas and/or it was flooded but the gas evaporated and left a lot of oil behind. Is the spark plug wet? Does it look wet when looking in the spark plug hole?
 
  #3  
Old 08-25-12, 08:21 PM
Member
Thread Starter
Join Date: Aug 2012
Posts: 2
no the piston and plug look normal, and it will pull easy with the plug out, but then hard again with the plug back in.
 
  #4  
Old 08-26-12, 12:53 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,820
I'd say you have bad bearings on the crankshaft.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes