snowblower runs 30 seconds then dies

Reply

  #1  
Old 08-31-12, 05:44 PM
Member
Thread Starter
Join Date: Jun 2012
Posts: 115
snowblower runs 30 seconds then dies

hi i have a very old hahn eclipse snow blower with a 4 stroke briggs and stratton engine that runs for about thirty seconds then it dies it only runs on full choke and i just put a new fuel filter on(before that it wouldnt run at all) i can see into the fuel filter when it dies and there is no fuel do i need a new fuel cap??
 
Sponsored Links
  #2  
Old 09-01-12, 04:39 PM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,728
It could the cap. Just loosen it to see if that fixes. If not you still have a fuel delivery problem that could be a restriction in a line or a plugged outlet at the gas tank..... that sort of thing

The running/dieing like yours is 99 percent of the time fuel delivery to the engine.
 
  #3  
Old 09-01-12, 08:19 PM
Member
Thread Starter
Join Date: Jun 2012
Posts: 115
great i just took the carb off and apart but thats what i thought because there was no fuel in the filter when it died
 
  #4  
Old 09-03-12, 12:14 PM
Member
Join Date: Sep 2012
Posts: 2
Your main jet is dirty. Very simple fix. The main jet is a bolt on the bottom of the bowl. Reminder taking the bolt out will that the bowl off so hold onto it. After taking the main jet out simply run carb cleaner through all the little holes in it make sure its nice and clean and it should run great!!
 

Last edited by cheese; 09-03-12 at 07:53 PM. Reason: removal of request to email
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes