Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

snowblower runs 30 seconds then dies


keystart's Avatar
Member

Join Date: Jun 2012
Posts: 115
PA

08-31-12, 05:44 PM   #1  
snowblower runs 30 seconds then dies

hi i have a very old hahn eclipse snow blower with a 4 stroke briggs and stratton engine that runs for about thirty seconds then it dies it only runs on full choke and i just put a new fuel filter on(before that it wouldnt run at all) i can see into the fuel filter when it dies and there is no fuel do i need a new fuel cap??

 
Sponsored Links
marbobj's Avatar
Member

Join Date: May 2006
Posts: 3,658
IA

09-01-12, 04:39 PM   #2  
It could the cap. Just loosen it to see if that fixes. If not you still have a fuel delivery problem that could be a restriction in a line or a plugged outlet at the gas tank..... that sort of thing

The running/dieing like yours is 99 percent of the time fuel delivery to the engine.

 
keystart's Avatar
Member

Join Date: Jun 2012
Posts: 115
PA

09-01-12, 08:19 PM   #3  
great i just took the carb off and apart but thats what i thought because there was no fuel in the filter when it died

 
greedy5575's Avatar
Member

Join Date: Sep 2012
Posts: 2
NE

09-03-12, 12:14 PM   #4  
Your main jet is dirty. Very simple fix. The main jet is a bolt on the bottom of the bowl. Reminder taking the bolt out will that the bowl off so hold onto it. After taking the main jet out simply run carb cleaner through all the little holes in it make sure its nice and clean and it should run great!!


Last edited by cheese; 09-03-12 at 07:53 PM. Reason: removal of request to email
 
Search this Thread