Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

B&S 18.5 HP engine Another Bad Cam - 3rd one


jl66redcpe's Avatar
Member

Join Date: Nov 2006
Posts: 369
NJ

09-06-12, 09:57 AM   #1  
B&S 18.5 HP engine Another Bad Cam - 3rd one

Well today I ran across my third B&S 18.5 HP engine with a bad cam/compression release. This one was mfg in 2004. Ironically, Sears had been out in the spring and adjusted the valves. I have had two of these this summer. The model is a 31p777 as they have all been in the 31xxx series. It seems to be only the 18.5 HP models that have the problem. This appears to be more than coincidence. Please comment.

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,574
GA

09-06-12, 06:47 PM   #2  
It started happening when they switched to the new style cam instead of the old cast iron one. I've been seeing a lot of them too in comparison to past years. It's just cheap junk parts that's causing the problem.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
jl66redcpe's Avatar
Member

Join Date: Nov 2006
Posts: 369
NJ

09-07-12, 05:01 AM   #3  
It is very frustrating as one thinks -- "heck the valves just need adjusting" and then after adjusting the result is the same. On the last two that this happened, I warned the owners that this particualr engine (18.5 hp OHV) could have a bad cam. I am so glad I did. It is not a real difficult repair except for getting that darn double pulley off.

 
Search this Thread