B&S 18.5 HP engine Another Bad Cam - 3rd one

Reply

  #1  
Old 09-06-12, 09:57 AM
Member
Thread Starter
Join Date: Nov 2006
Location: South Jersey
Posts: 383
B&S 18.5 HP engine Another Bad Cam - 3rd one

Well today I ran across my third B&S 18.5 HP engine with a bad cam/compression release. This one was mfg in 2004. Ironically, Sears had been out in the spring and adjusted the valves. I have had two of these this summer. The model is a 31p777 as they have all been in the 31xxx series. It seems to be only the 18.5 HP models that have the problem. This appears to be more than coincidence. Please comment.
 
Sponsored Links
  #2  
Old 09-06-12, 06:47 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
It started happening when they switched to the new style cam instead of the old cast iron one. I've been seeing a lot of them too in comparison to past years. It's just cheap junk parts that's causing the problem.
 
  #3  
Old 09-07-12, 05:01 AM
Member
Thread Starter
Join Date: Nov 2006
Location: South Jersey
Posts: 383
It is very frustrating as one thinks -- "heck the valves just need adjusting" and then after adjusting the result is the same. On the last two that this happened, I warned the owners that this particualr engine (18.5 hp OHV) could have a bad cam. I am so glad I did. It is not a real difficult repair except for getting that darn double pulley off.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes