Generac Generator

Reply

  #1  
Old 11-02-12, 07:21 PM
Member
Thread Starter
Join Date: Dec 2004
Location: NJ
Posts: 250
Generac Generator

I have an older 5000 watt Generac generator. I think the model is 09719-3.
Ran fine for 3 days (on and off)- now won't start- I drained all gas and put in new gas and new fuel filter- changed the oil etc..... getting a spark- When I put gas directly in spark plug hole- she fires for a sec- Could this be a coil issue? How do you know if the coil is bad?? Not sure what else it could be
 
Sponsored Links
  #2  
Old 11-02-12, 08:42 PM
Member
Join Date: Mar 2006
Location: Wet side of Washington state.
Posts: 18,399
If you get a good fat blue spark the coil is not the problem. Have you checked the spark plug gap? It should be about .025 of an inch. If that part is okay then it is either a problem of low compression or not enough fuel delivery.
 
  #3  
Old 11-02-12, 09:28 PM
Member
Join Date: Oct 2011
Location: USA
Posts: 433
Check and make sure fuel is turned on, if fuel filter is in line check it, also make sure fuel is flowing through hose to Carburetor. If fuel is going to Carb check to see if fuel is going into float bowl, the should be a bolt off center in float bowl take it out and check for JUNK in gas coming out and if that fails take carb off and clean. Good luck.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes