Lawn trimmer won't run

Reply

  #1  
Old 04-22-13, 11:06 AM
Member
Thread Starter
Join Date: Apr 2012
Posts: 34
Lawn trimmer won't run

Re: Craftsman 32cc 2 cycle Model 358.791800 Weedwacker
This unit has always done me well, started easy, run fine. Took it out of winter hibernation yesterday and it started within in a reasonable number of pulls but couldn't keep it running. Finally it seemed that it would run and I proceeded to trim the yard. However, to keep it running I had to continuously pump the trigger, even then it would eventually die. But one pull and it was running again. It seem to run fine at idle, just not under load. If it had a fuel pump I would have suspected a weak pump. Today I removed the gas tank and engine (if that's what that little thing is), blew out all the lines and the filter inside the tank. Put it back together and still will not run. Even tried without the in-tank filter. Starts right up, but as soon as gas in bulb is burned up it quits. Hate to throw it away but I don't want to spend a lot on a $100+ unit that's probably 4-5 years old.
 
Sponsored Links
  #2  
Old 04-22-13, 11:46 AM
Member
Join Date: Oct 2011
Location: USA
Posts: 433
Check for cracked fuel lines and take carburetor apart and check for hard diaphragm or plugged screen inside carburetor. If diaphragm and pump are hard replace with carb kit. This wonderful gas we have to deal with that has 10% ethanol in it will leave a film on the screen and gas will not flow through it. Good Luck
 
  #3  
Old 04-22-13, 12:00 PM
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 17,753
I would give the carburetor a good cleaning. You could have a clogged jet or orifice. Just in case Sears has the carb for $28.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes