Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

weedeater featherlite fl20 wont idle, cuts off under load


cc3337's Avatar
Member

Join Date: Jan 2013
Posts: 8
NC

04-22-13, 02:30 PM   #1  
weedeater featherlite fl20 wont idle, cuts off under load

Hello
i have an fl20 featherlite weedeater it has ran great for about 5 yrs and now it will not run, when cranked it immediately dies, and if it does run a few seconds it dies under load, when i move the choke lever to choke and back to run it revs up high and dies again, could anyone help me troubleshoot this problem? i have taken the muffler off to check spark arrestor clogging and also sprayed carb cleaner in the mouth of the carb while running

thanks

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

04-22-13, 05:03 PM   #2  
The carb needs cleaning. Might want to check the fuel lines too.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
cc3337's Avatar
Member

Join Date: Jan 2013
Posts: 8
NC

04-22-13, 07:05 PM   #3  
Hi
could you tell me how you go about cleaning a carb this small, i dont even see any jets, just the mouth of the carb with the butterfly that opens and closes
thanks

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

04-22-13, 07:40 PM   #4  
You have to take it off and apart. Make note of how it all comes apart so you can put it back together properly. A digital camera might help.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
cc3337's Avatar
Member

Join Date: Jan 2013
Posts: 8
NC

04-23-13, 06:49 AM   #5  
cheese
thanks, i was able to find a youtube video and took the carb apart and cleaned, i was very careful with everything, everything went back together nicely and now the machine wont start, any suggestions as to what i have done?
thanks for your time

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

04-23-13, 09:48 AM   #6  
Double check the gaskets and diaphragms and make sure they aren't backwards, upside down, or in the wrong order.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
cc3337's Avatar
Member

Join Date: Jan 2013
Posts: 8
NC

04-23-13, 01:21 PM   #7  
Not sure what it was, put in fresh gas, pulled a few more times, now running like new after the carb clean, idles great

thanks so much

 
Search this Thread