2-cycle starts but only stays running by throttling between choke and full.


  #1  
Old 05-01-13, 10:48 AM
O
Member
Thread Starter
Join Date: May 2013
Location: usa
Posts: 2
Received 0 Votes on 0 Posts
2-cycle starts but only stays running by throttling between choke and full.

I suppose this will be the millionth post for rough running 2 cycles, but I can't seem to find a similar situation to mine.

I have a Tecumseh 2 cycle engine that, previously, would start only by adding fuel to the cylinder, then stall. I changed the diaphragm and now it starts without priming but will stall if you don't keep the throttle moving between choke and full. It will stall if you leave it on choke alone and won't stay running unless the throttle is constantly revved at a "sweet spot" just below choke. It is a rolling weed trimmer and continues to run the same way when load is applied (engaging the trimmer head). Any suggestions? This trimmer is a monster and I would really like to save this machine.

Thanks, Marc
 
  #2  
Old 05-01-13, 01:19 PM
G
Member
Join Date: Jun 2006
Location: United States
Posts: 2,471
Received 11 Votes on 11 Posts
Here is a link to the manual for Tec 2-cycle engines. Have a good one. Geo

http://www.smallenginesuppliers.com/...nformation.pdf
 
  #3  
Old 05-01-13, 09:11 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 17,600
Received 54 Votes on 49 Posts
Sounds like the carb needs a good cleaning.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: