power washer problems


  #1  
Old 05-22-13, 01:14 PM
T
New Member
Thread Starter
Join Date: Mar 2003
Location: PA
Posts: 403
Upvotes: 0
Received 0 Upvotes on 0 Posts
power washer problems

I have a 5 hp craftsman power washer with a brigg and Stratton motor....having trouble getting a spark.....been sitting since last year...brought it out gassed it up and it fired up and then quit...could not restart......checked the plug for spark and had none....bought a new plug and had spark....fired it up and run the washer for 1 1/2 hr no problems.....turned the washer off for an hour or so and could not restart it....checked and had no spark....cleaned things up and still nothing.....stopped at a small engine shop and picked up a used coil.....he did tell me the briggs coils usually do not go bad.....and he told me to check for the kill switch...(wires coming off the coil) they all looked good ....making good contact.....what else should I check for?....thanks
 
  #2  
Old 05-22-13, 01:42 PM
I
Member
Join Date: May 2013
Location: United States
Posts: 42
Upvotes: 0
Received 0 Upvotes on 0 Posts
Do you know if it has an automatic choke attached to the carburetor? If it does happen to have an auto choke, it might not be functioning properly and causing it to get choked when it is hot from running but it doesn't need to be. To find out if it has an auto choke, take the shroud off the motor and look for an air vane. That vane senses the temperature of the motor to see if it needs to be choked or not. If it has that kind of choke, it is probably not functioning properly, therefore causing it not to start.
 
  #3  
Old 05-22-13, 02:26 PM
M
Forum Topic Moderator
Join Date: Mar 2005
Location: USA - N.E.Tn
Posts: 45,770
Received 869 Upvotes on 760 Posts
Have you checked the oil level? is the PWer sitting on level ground?
 
  #4  
Old 05-22-13, 03:53 PM
T
New Member
Thread Starter
Join Date: Mar 2003
Location: PA
Posts: 403
Upvotes: 0
Received 0 Upvotes on 0 Posts
it has a manual choke in front with the speed lever.....it does have an auto shutoff if the oil is low......checked and it seems to be full.....they say to fill it to the top.....will try to add more....thanks
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: