Troubleshooting 18.5 BS Intek v-twin


  #41  
Old 07-23-13, 07:52 PM
HammerTime's Avatar
Member
Thread Starter
Join Date: Jan 2009
Location: Midwest
Posts: 33
Received 0 Votes on 0 Posts
I can pretty much hold it wide open and the governor doesn't seem to pull back with any pressure at all. The only real tension seems to come from the springs when the gov swivel gets to about 75%. Till then they are completely slack. Is that correct?

Right now my money is on something not right with the governor internally. With it not running, should there be tension one way or the other on the governor shaft? And with it running, it should pull clockwise with more force as the rpms increase - right?
 
  #42  
Old 07-23-13, 10:10 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 17,661
Received 56 Votes on 51 Posts
Your governor isn't in place properly inside. It should pull back hard to slow down the engine.
 
  #43  
Old 07-24-13, 06:01 AM
HammerTime's Avatar
Member
Thread Starter
Join Date: Jan 2009
Location: Midwest
Posts: 33
Received 0 Votes on 0 Posts
Ok. Was gonna take it in & have the linkage looked at, but think I'll split it open again & see what I can make of the governor. Probably won't get to it for a few days - also need to get a pan gasket & pto seal I guess.

Hope you don't mind if I ping you again once I get it open.

Thanks for your help & patience.

Steve
 
  #44  
Old 07-24-13, 09:50 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 17,661
Received 56 Votes on 51 Posts
No problem, we're here to help.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: