Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

transmission problems on Murray Riding lawnmower


kyle johnson's Avatar
Member

Join Date: Oct 2004
Posts: 150
AL

07-01-13, 01:10 PM   #1  
transmission problems on Murray Riding lawnmower

It's a 14 hp ... 42" cutting deck
It just quit going ....5th gear....1st gear....it doesn't matter
Do I need to put transmission fluid in it??
Maybe tighten up something?

Thanks

 
Sponsored Links
joecaption1's Avatar
Banned. Rule And/Or Policy Violation

Join Date: Apr 2013
Posts: 4,297
VA

07-01-13, 01:19 PM   #2  
Without at least a model and ser. # how would we know?

 
Dixie2012's Avatar
Forum Topic Moderator

Join Date: Sep 2012
Posts: 571
LA

07-01-13, 02:44 PM   #3  
And, "it just quit going"? Like you put on the brakes or did it coast to a stop or did it gradually stop moving over the past, say 2 mowings or 4 mowings? Or was it running fine like it always does then 3 feet later it was not going anywhere?
Did it growl, grind, squeak or squeal? Did it bump or jerk? Did it make a noise? Did it NOT make a noise?
Was you going up hill, level or down hill?

 
mowerdude's Avatar
Member

Join Date: Oct 2011
Posts: 433
AR

07-01-13, 02:47 PM   #4  
Check for a broken belt dude!

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,575
GA

07-01-13, 09:31 PM   #5  
I agree, the belt most likely came off.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread