Snapper with B&S 675 engine wont start

Reply

  #1  
Old 07-18-13, 09:19 PM
Member
Thread Starter
Join Date: Jul 2013
Location: US
Posts: 1
Snapper with B&S 675 engine wont start

I have a "new to me" Snapper self propelled mower that will not start. When I got the mower it had no fuel in it. I put fresh gas in it and it would not start.

I have checked the spark and it is getting good spark(has new plug). I have checked fuel flow into bowl and it is good. I have taken carb off and ran cleaner through it and it seems to be pretty clean and looks as if everything is working in good order. I have sprayed carb cleaner into carb and mower will start briefly then stop. It may run for 1-3 seconds then dies.

It appears to me like it is not getting fuel but I am not sure. I have never had a set up quite like this. There is no throttle control, primer bulb or choke.

What else do I need to check to make sure it is getting fuel, or am I in left field?

Thanks

Chris
 
Sponsored Links
  #2  
Old 07-19-13, 12:51 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,575
Take the bolt out that holds the carburetor bowl on. There are holes going through the sides and the center of it. Clean these holes out and see how it does.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 12:13 AM.