Briggs Vanguard motor will not throttle up

Reply

  #1  
Old 09-01-13, 03:12 PM
Member
Thread Starter
Join Date: Sep 2013
Location: United States
Posts: 1
Briggs Vanguard motor will not throttle up

I have a Briggs vanguard motor 28Q777-0691-E1. It starts and idles fine but will not rev up very well. It acts like it is hitting a governor or something. I have replaced the fuel pump and replaced the electrical plug at the bottom of the Carburetor. If I reach in and try to rev it with the throttle it revs up but is just flat. any suggestions?
thanks
 
Sponsored Links
  #2  
Old 09-01-13, 04:34 PM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,728
If you're opening the throttle directly by hand and it's going nowhere, it's probably a fuel supply issue. It could be before the carb or inside it.

If you have a fuel pump, disconnect the fuel line from the carb and spin the engine over. Catch the fuel in a jar so you can see how much it's pumping.

If no pump, then disconnect the line and check it for a full stream. If it's just a trickle, work your way back up to the fuel supply and check for obstructions or a plugged filter.

If you have a good flow to the carb, you'll have to take the carb off and clean it.
 
  #3  
Old 09-16-13, 10:26 AM
Member
Join Date: Sep 2013
Posts: 4
Internal governor might be broke.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes