Honda HS520A snowblower - Choke rod and knob disconnected


  #1  
Old 01-07-14, 03:50 PM
P
Member
Thread Starter
Join Date: Dec 2006
Location: US
Posts: 6
Received 0 Votes on 0 Posts
Honda HS520A snowblower - Choke rod and knob disconnected

I bought Honda HS520A snowblower last month.
It had been working fine until today when I tried to start it again.
When I pulled the choke out, the know along with the rod came off.
(a picture attached)

How do I put it back?

Name:  IMG_2111[1].jpg
Views: 2015
Size:  12.5 KB
 
  #2  
Old 01-07-14, 10:57 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 61,856
Received 1,479 Votes on 1,367 Posts
It looks like there is a little plastic sleeve that holds it in place. You appear to be missing it.

Name:  3.jpg
Views: 1870
Size:  5.9 KB

In the parts breakout, part 1, it's called a cord grommet, which looks incorrect.
Parts and Diagrams for Honda HS520 ASA SNOW BLOWER, USA
 
  #3  
Old 01-08-14, 06:22 AM
P
Member
Thread Starter
Join Date: Dec 2006
Location: US
Posts: 6
Received 0 Votes on 0 Posts
PJmax, thank you for replying to my question promptly.

I will look for the plastic piece which I must have dropped.

I looked at the parts' diagram, but I could not figure out which hole the bent end of the choke rod goes into.

Since it has a 'S' curve, it must goes through a hole big enough, but small enough to retain it.

Can you help me find the hole?

Thank you.
 
  #4  
Old 01-12-14, 09:26 AM
P
Member
Thread Starter
Join Date: Dec 2006
Location: US
Posts: 6
Received 0 Votes on 0 Posts
I had a warranty service performed on this....

I was told that I needed to take the cover off to do anything to begin with. I tried to take the cover off and I could not, so I took it to a Honda-authorized repair shop.

Thank you for your help.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: