Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Cummins 3000 generator no voltage output


TOMN8ER2's Avatar
Member

Join Date: Dec 2013
Posts: 5
IL

01-12-14, 12:23 PM   #1  
Cummins 3000 generator no voltage output

Hello, I have a Cummins 3000 Generator with a JF 200 Jiangdong 6.5 hp motor.
the motor starts right up, however, I get no AC output. I had bought a new AVR thinking that was the issue. While replacing the AVR I noticed a broken connector on a wire. I fixed that connection and even with the old AVR, I had power output. Put Generator in back of my pick up and drove home, and got home, an no voltage output, even with new AVR. I re-re-checked my wire connections etc., and see no obvious issues. Brushes look kinda worn down, but it worked before the drive home,
Any ideas on what I can look for here? I have not tested AC while running yet, I did before I got it working, but not since, so I don't have result for the different points. I will do that here soon though. In the mean time, any thoughts????? Thank you in advance for any ideas.
Tom

 
Sponsored Links
TOMN8ER2's Avatar
Member

Join Date: Dec 2013
Posts: 5
IL

01-12-14, 12:26 PM   #2  
p.s.

p.s. I did take the control panel off and check the wire connections, circuit breaker and kill switch, etc. , all looked ok. tested breaker ok

 
Justin Smith's Avatar
Member

Join Date: Dec 2010
Posts: 2,546
PA

01-14-14, 09:03 AM   #3  
Try flashing it. You can find how-to videos on Youtube.

 
Search this Thread