Craftsman Snow Blower - Starts but does not run.

Reply

  #1  
Old 01-18-14, 10:22 AM
Member
Thread Starter
Join Date: Aug 2009
Location: New Jersey USA
Posts: 1
Craftsman Snow Blower - Starts but does not run.

Starting the snow blower is no problem but it only runs for about 30 seconds. I dropped the carb bowl and sprayed carb cleaner in the jets and bowl with no results. Any suggestions to get it running. The engine is a Briggs 8hp.
 
Sponsored Links
  #2  
Old 01-18-14, 12:02 PM
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 17,768
Does the float go up and down freely? Is the needle still attached to the float and does it move up and down without sticking?

Spraying carb cleaner around can sometimes help but it's not the best. I would remove the carburetor, disassemble and soak in cleaner. Give it a thorough cleaning and re-assemble.
 
  #3  
Old 01-29-14, 01:22 PM
Banned. Rule And/Or Policy Violation
Join Date: Dec 2013
Location: USA
Posts: 3
Use a can of compressed air (like the kind they used on computer keyboards) and blow out every hole and orifice in the carburetor. Carb cleaner can clean the pathway, but you need to find the clog that is causing the issue.

Also, may sure your Air Filter is on properly and everything is sealed up tight. Otherwise Maverick air will get in...

In case you need a basic Manual, I recommend this site--> Briggs And Stratton Care & Repair Booklet For $3! Small Engine Repair;tradebit;download Briggs And Stratton;care And Repair
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes