JD 524D auger turns slow

Reply

  #1  
Old 01-22-14, 10:17 AM
Member
Thread Starter
Join Date: Nov 2011
Location: U.S
Posts: 41
Unhappy JD 524D auger turns slow

Greeting,

The auger on my JD 524D snowblower turns slow. It won't shoot the snow fast and snow are stuck in there. The shear bolts are all in good shape. What could cause this problem? the belt?

Thanks.
 
Sponsored Links
  #2  
Old 01-31-14, 07:35 AM
Member
Thread Starter
Join Date: Nov 2011
Location: U.S
Posts: 41
The impeller runs perfect and the auger belt isn't loose when engage the handle bar. it's hard to tell if the belt is slippery while the machine is running and auger is engaging. Since it is over 10 yr old blower, maybe the belt lost its tension. I ordered the new auger belt and will replace it this weekend. Will updating this thread soon....
 
  #3  
Old 02-04-14, 08:31 AM
Member
Thread Starter
Join Date: Nov 2011
Location: U.S
Posts: 41
replaced the auger belt yesterday but no luck
 
  #4  
Old 02-04-14, 12:23 PM
Member
Join Date: Mar 2009
Location: USA
Posts: 628
The JD

The impeller may be spinning on it's shaft, with the engine off, and maybe the spark plug wire off, and the belt engaged, try to move the impeller, you may get lucky .
Sid
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes