Murray 27" two stage snow blower only goes foward at full speed


  #1  
Old 02-03-14, 02:56 PM
E
Member
Thread Starter
Join Date: Aug 2013
Posts: 143
Received 0 Upvotes on 0 Posts
Murray 27" two stage snow blower only goes foward at full speed

My Murray snowblower just started screwing up. It's only going forward at full speed. Usually I could chose a speed between 1-6 forward or 1-2 in reverse, higher being faster. Now, no matter what position I've got the stick, it only moves foward very quickly. The stick does seem to move the bar it is attached to (going into the engine) up and down correctly.

Unfortunately I don't have a more specific model number right now. But does anyone have any suggestions on what the problem might be?

Thanks
 
  #2  
Old 02-04-14, 05:18 AM
S
Member
Join Date: Mar 2009
Location: USA
Posts: 583
Upvotes: 0
Received 1 Upvote on 1 Post
The Murray

Your going to have to take the bottom cover off, and observe the actions if the speed control levers and clutch handles as you move them through the speeds, and forward, and reverse. You should be able to see something wrong.
Sid
 
  #3  
Old 02-05-14, 05:07 AM
E
Member
Thread Starter
Join Date: Aug 2013
Posts: 143
Received 0 Upvotes on 0 Posts
Damn, I really wish I saw this yesterday... a half hour ago I was like, there was some forum I just subscribed to a topic about, but couldn't for the life of me remember where or what it was...Then just now I was thinking about having to go out in the freezing rain and clear off the sidewalk and it clicked... Wish I had a chance to work on this yesterday...Oh well.

Thanks again for the reply, I will check it and report back.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: