Governor problems

Reply

  #1  
Old 03-10-14, 03:58 PM
bob1908's Avatar
Member
Thread Starter
Join Date: Apr 2009
Location: land of lincoln
Posts: 129
Governor problems

hi all i got a kolar commander 15.0 hp with oli pump and filter model cv15s when i start the motor it run in full chock but when you move the laver to fast it runs real high idel but then die i disconnected the gov and the gov does not move controlling the mortor speed but i can move the gov by hand any idea what it can be???????
 
Sponsored Links
  #2  
Old 03-10-14, 05:50 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,813
Can you make it idle well without dying or keeping the choke on? Those engines are notorious for the throttle shaft wearing out and breaking, holding the throttle valve open.
 
  #3  
Old 03-10-14, 06:36 PM
bob1908's Avatar
Member
Thread Starter
Join Date: Apr 2009
Location: land of lincoln
Posts: 129
gov

no it wont stay running with choke open it has to have some choke to keep running i chk the butterfly on the throdl and it moving just fine i chk for end play on it dont move side to side but would that cause the gov not to work @ all so assuming it mite need a new carb thats about 150.00 for that carb right
 
  #4  
Old 03-14-14, 01:09 PM
bob1908's Avatar
Member
Thread Starter
Join Date: Apr 2009
Location: land of lincoln
Posts: 129
does anybody have a break down of the motor kolar command cv15s
 
  #5  
Old 03-14-14, 02:05 PM
Rough Rooster's Avatar
Member
Join Date: Feb 2014
Location: USA
Posts: 381
http://www.searspartsdirect.com/part...&prst=&shdMod=

Really can't know what you need until engine disassembly and find what has broken or slipped out of place.

RR
 
  #6  
Old 03-14-14, 11:38 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,813
The not running without being choked is a carb problem. The revving up problem might be the governor gear slipped off the shaft. Seen it a time or two on these engines.
 
  #7  
Old 04-09-14, 09:53 AM
bob1908's Avatar
Member
Thread Starter
Join Date: Apr 2009
Location: land of lincoln
Posts: 129
gov problem

ok i took the kolar apart found the govner gear and all it parts sitting bottom of motor i got it all back to gether but how do u adlust the govr linkage from the gov shaft to the carb
 
  #8  
Old 04-15-14, 10:58 AM
bob1908's Avatar
Member
Thread Starter
Join Date: Apr 2009
Location: land of lincoln
Posts: 129
gov problem

ok good news i got gov in place and reassembled and adjusted and running but......
can any one tell me if the valves are adjuastable on this motor i hate to take the valve cover off the motor to find they are not adjustable
here the specs on motor
year code is a 25=1995
fam is skh426u1g2rb
model cv15s
spec 14519
dspl 426
from this info can anyone tell if it has adjuastable valves or not ??????
 
  #9  
Old 04-15-14, 05:18 PM
Rough Rooster's Avatar
Member
Join Date: Feb 2014
Location: USA
Posts: 381
ok good news i got gov in place and reassembled and adjusted and running but......
can any one tell me if the valves are adjuastable on this motor i hate to take the valve cover off the motor to find they are not adjustable
here the specs on motor
year code is a 25=1995
fam is skh426u1g2rb
model cv15s
spec 14519
dspl 426
from this info can anyone tell if it has adjuastable valves or not ??????
In a word -- YES.

RR
 
  #10  
Old 04-15-14, 06:44 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,813
Actually, No.

This engine has hydraulic lifters.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes