B&S 24 hp spitts & spudders & smokes & revs up & down

Reply

  #1  
Old 05-03-14, 04:29 PM
Member
Thread Starter
Join Date: Aug 2013
Location: usa
Posts: 14
B&S 24 hp spitts & spudders & smokes & revs up & down

I have a B & S 24 hp v twin intec 44m7770790b1 and when I start it, it acts like the choke is sticking smokes spits & spudders & if I hold up on the throttle linkage (closing it) it straightens out but it won't keep a steady idle it goes up and down & has a slight miss at low idle and gets worse at high idle. What I've done to this point is new fuel & air filters new fuel pump tried rebuilding the carb twice adjusted coils but haven't checked for spark new plugs adjusted governor(question how do you know if it's bad?) (I took off governor linkage & manually choked to start and I can still turn the shaft when it's running same as when it's not) but once I hold up on linkage & it stops spuddering it seems okay with the exceptionof the slight miss, until you turn off & start again. I did notice that intake manifold isn't flush with carb it has a slight gap in the middle I heated it with a lighter & used a screw driver to get it close & put an extra gasket it to fill the gap & silicone around outside of it. but I'm going to order a new one just don't know if it's a carb or a governor problem oh and has new governor lever old one got bent trying to make adjustments throttle linkage tweeked but is as straight as I can get it till new one comes. Any & All help is Greatly Appreciated Thanks For Looking & Helping been messing with this for a year can't afford to go buy another one this one is three years old THANKS AGAIN
 
Sponsored Links
  #2  
Old 05-05-14, 04:11 PM
Member
Thread Starter
Join Date: Aug 2013
Location: usa
Posts: 14
well I'm thinkin it's the carb and while I'm at it ordered a new intake manifold pay'n $160 bucks is still cheaper than takin it to the shop at $95 an hour
 
  #3  
Old 05-07-14, 03:58 PM
Member
Thread Starter
Join Date: Aug 2013
Location: usa
Posts: 14
Woo Hoo it's back to the way it should be it was the carburetor still don't know what is wrong with the old one. also once I held up on the throttle linkage after starting it ran fine but if I had the throttle up too high when mowing it would start bogging out but at half throttle it would run fine. hopefully this helps someone
 
  #4  
Old 05-07-14, 04:21 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
Glad got got it figured out. I was going to suggest more carb cleaning after reading the first post, but I see you got it!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes