Carburator repair kit for Kohler engine on Husqvarna lawn mower

Reply

  #1  
Old 05-07-14, 08:48 AM
Member
Thread Starter
Join Date: Dec 2013
Location: USA
Posts: 20
Carburator repair kit for Kohler engine on Husqvarna lawn mower

I've had this Husqvarna 6021p (http://www.husqvarna.com/ddoc/HUSO/H...en_431621_.pdf) mower for maybe two years. It was stored in a storage unit for a few months (probably not level) with some gas in it (I thought it was empty, it wasn't). It wouldn't start even before being stored. I changed the gas and spark plug and dismantled the bottom of the Carburator to clean it out. Engine oil was clean and level was ok. The engine is a Kohler XT(http://www.kohlerengines.com/onlinec..._14_690_01.pdf) and this is the carburator (Amazon.com: Kohler 14-853-49-S Kit,Carburetor: Industrial & Scientific). After reassembling, it still would not start. I assume I didnt clean the carb out well enough (I just cleaned out the bottom which was pretty gunked up, not any of the other ports), but I would like to use a carb repair kit, something like this (Repair Kit 14 757 03-S Order now for same day shipping. 365 day return policy. RepairClinic.com) but I don't know how to find the proper one.

Additionally, I think the ignition module may not be producing spark, I am doing the test where you ground the spark plug to metal on the engine and turn the flywheel and getting no spark. I can find this piece easy enough, but also wondering if I am doing anything wrong there.

I am a total noob at engines, but I would love to try to fix this myself rather than pay someone or trash the thing.
 
Sponsored Links
  #2  
Old 05-07-14, 09:57 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,815
I'd focus on spark before the carb, otherwise how will you know when the carb is clean enough to function properly. Check the kill switch where the deadman bar cable connects. Make sure it is turning the ignition on.
 
  #3  
Old 05-08-14, 07:02 AM
Member
Thread Starter
Join Date: Dec 2013
Location: USA
Posts: 20
Thanks! Actually I did check again and I am getting spark. So back to the carb I guess.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes