Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Kawasaki FE250 runs rough


dbsoccer's Avatar
Member

Join Date: Jan 2010
Posts: 70

05-07-14, 09:32 AM   #1  
Kawasaki FE250 runs rough

I own a Ryan LawnAire 28 with an 8hp Kawasaki FE250 engine. The engine starts fine but seems to stumble and, in general, run rough.

The engine has much less than 100 hours on it despite being a pre-2000 vintage. The unit was first used in Cleveland but I'm using it at 5,000 feet in Colorado. Before digging into this I was hoping to get some insight from some of the online experts who may have some ideas. The aircleaner, while not new, is not terribly dirty and the choke seems to work as designed.

Any help or ideas would be greatly appreciated.

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

05-07-14, 10:00 AM   #2  
My first thought is probably carburetor. I assume you tried a new plug.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
dbsoccer's Avatar
Member

Join Date: Jan 2010
Posts: 70

05-07-14, 10:16 AM   #3  
Thanks Cheese,

I actually haven't touched it. I did check the air cleaner but did that as a matter of spring start up, etc. I can easily swap out the plug and see if that helps but, like you, I feel it's a fuel issue.
The manual indicates that only authorized Kawasaki repair people should mess with the carburetor but it's just a single barrel carburetor. I was hoping someone has some experience with the carburetor on this engine that may have some ideas. Thanks.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

05-07-14, 04:16 PM   #4  
Yeah, it's just a simple carburetor. A normal cleaning may take care of it.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread