Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

John deere gas weed eater not spinning


diy_in_atl's Avatar
Member

Join Date: Sep 2009
Posts: 230
GA

05-19-14, 06:16 PM   #1  
John deere gas weed eater not spinning

I've got a john deere weed eater. It's the 2-stroke 50:1 gas oil model. The engine runs fine, but periodically the weed eater part won't spin. I attached the hedge trimmer and the same thing happened. If I jiggle the end and tilt the end up then it'll sometimes start spinning. Is What do I need to get this working again? I looked in the shaft and it looks like the shaft with the square in it is spinning properly.

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,569
GA

05-19-14, 08:29 PM   #2  
Sounds like the motor might need to be pushed down onto the shaft a bit more and the clamp bolts tightened. John deere put their name on a whole bunch of different trimmers, so saying "it's the 2-stroke 50:1 gas oil model" doesn't tell us what you have. The advice I gave would apply to pretty much all of them though, but the specifics would be different according to model.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
diy_in_atl's Avatar
Member

Join Date: Sep 2009
Posts: 230
GA

05-20-14, 04:56 AM   #3  
It's a BC1600. How to I push that spinning bolt forward? Is there a screw or clip or something like that?

 
Search this Thread