Power Washer No Pressure

Reply

  #1  
Old 06-18-14, 06:41 PM
P
Member
Thread Starter
Join Date: Jun 2014
Location: usa
Posts: 2
Received 0 Votes on 0 Posts
Power Washer No Pressure

Hello,

I have a pressure washer with no pressure, After reading many comments and forums, I purchased a new unloader valve with no success, I has just purchased and installed a new pump, and still no luck?

Everything appears to be functioning properly until I squeeze the handle, I get a very short burst of pressure and the normal water pressure??

Any suggestions and help would be greatly appreciated. My wife suggested I just buy a new washer, but NO, I assured her I could fix this one. Help me out here and help all mankind

Thank you!

Craig
 
  #2  
Old 06-18-14, 11:11 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 17,560
Received 48 Votes on 43 Posts
So now your pump is new but still no pressure? Then either the supply is poor or the new pump is bad. The short burst of pressure makes me think the pump is good and the supply is poor or you have the wrong tip on the wand (soap tip).
 
  #3  
Old 06-19-14, 05:07 AM
Geochurchi's Avatar
Member
Join Date: Nov 2012
Location: United States
Posts: 4,964
Received 88 Votes on 83 Posts
Are your supply hoses tight,if it is pulsating and low pressure it could be sucking air,don't use quick couplings on the hoses,it happened to me.
Geo
 
  #4  
Old 06-19-14, 05:53 AM
M
Forum Topic Moderator
Join Date: Mar 2005
Location: USA - N.E.Tn
Posts: 47,844
Received 361 Votes on 318 Posts
I use the quick disconnects and never have had any issues with them.

Before I start my PWer I always 'prime' the pump by pulling the trigger and making sure I have a good stream of water [no air] first.
 
  #5  
Old 06-19-14, 05:09 PM
P
Member
Thread Starter
Join Date: Jun 2014
Location: usa
Posts: 2
Received 0 Votes on 0 Posts
Well, I want to thank you all for your advice. I decided to purchase a new hose and spray handle, and it is working great! I sure can't explain why that fixed the problem, but it did. My wife is very pleased that I fixed it especially since I have now invested more than $300.00 in and old power washer. All I can say is? Actually there is not much I can say except, I'm sure glad it works, I can't imagine the hell I would have experienced if I had spent the $300 and it didn't work!!!!!!!!!!

Thanks again for all your advice!
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: