Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Power Washer No Pressure


Power failure's Avatar
Member

Join Date: Jun 2014
Posts: 2
VA

06-18-14, 05:41 PM   #1  
Power Washer No Pressure

Hello,

I have a pressure washer with no pressure, After reading many comments and forums, I purchased a new unloader valve with no success, I has just purchased and installed a new pump, and still no luck?

Everything appears to be functioning properly until I squeeze the handle, I get a very short burst of pressure and the normal water pressure??

Any suggestions and help would be greatly appreciated. My wife suggested I just buy a new washer, but NO, I assured her I could fix this one. Help me out here and help all mankind

Thank you!

Craig

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,571
GA

06-18-14, 10:11 PM   #2  
So now your pump is new but still no pressure? Then either the supply is poor or the new pump is bad. The short burst of pressure makes me think the pump is good and the supply is poor or you have the wrong tip on the wand (soap tip).


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Geochurchi's Avatar
Member

Join Date: Nov 2012
Posts: 2,973
NH

06-19-14, 04:07 AM   #3  
Are your supply hoses tight,if it is pulsating and low pressure it could be sucking air,don't use quick couplings on the hoses,it happened to me.
Geo

 
marksr's Avatar
Forum Topic Moderator

Join Date: Mar 2005
Posts: 42,810
TN

06-19-14, 04:53 AM   #4  
I use the quick disconnects and never have had any issues with them.

Before I start my PWer I always 'prime' the pump by pulling the trigger and making sure I have a good stream of water [no air] first.


retired painter/contractor avid DIYer

 
Power failure's Avatar
Member

Join Date: Jun 2014
Posts: 2
VA

06-19-14, 04:09 PM   #5  
Well, I want to thank you all for your advice. I decided to purchase a new hose and spray handle, and it is working great! I sure can't explain why that fixed the problem, but it did. My wife is very pleased that I fixed it especially since I have now invested more than $300.00 in and old power washer. All I can say is? Actually there is not much I can say except, I'm sure glad it works, I can't imagine the hell I would have experienced if I had spent the $300 and it didn't work!!!!!!!!!!

Thanks again for all your advice!

 
Search this Thread