Toro PP Model 20055 Drive problem

Reply

  #1  
Old 06-18-14, 06:46 PM
Member
Thread Starter
Join Date: Jun 2014
Location: USA
Posts: 3
Toro PP Model 20055 Drive problem

I have a 2007 Toro personal pace mower that is having issues with the left wheel/drive. It makes a clicking sound when you push it with the mower off and it also makes the noise while running. The wheel also has a lot of play in it. I can move it in and out a bit. I read on another thread that it could just be the clutch washer and maybe the bearings. Both wheels spin freely when they are engaged off of the ground. The left one does have issues when you put some pressure on it. It still mows but it does at times pull to the one side. Hoping to fix it before it gets any worse. Thanks in advance for any help and or ideas.
 
Sponsored Links
  #2  
Old 06-18-14, 10:16 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,821
All I can suggest is that you take the wheel off and see what is causing the problem, whether it's a bearing or something broken or worn out wheel.
 
  #3  
Old 06-19-14, 08:30 AM
Member
Thread Starter
Join Date: Jun 2014
Location: USA
Posts: 3
I think I found the problem. I have a broken C clip on the inner assembly. I have ordered some from Toro and I will report back if that fixed the problem. Thanks
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes