Hi pressure pump

Reply

  #1  
Old 06-25-14, 01:34 PM
Member
Thread Starter
Join Date: Nov 2012
Location: USA
Posts: 3,262
Hi pressure pump

Hi All,my hi pressure washer stopped working,no pressure, it's a Annovi Reverberi Mdl RMV 2.5G27D I have disassembled the wetend of the pump and everything is clean and free,my only question is there are 3 stainless steel pistons on the opposite end ,should I be able to push them in?
Thanks Geo
 
Sponsored Links
  #2  
Old 06-25-14, 10:28 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,818
If you are pushing from the outside in, no, they won't push in because the spring is already holding them in. They should move as you rotate the engine though.
 
  #3  
Old 06-26-14, 04:19 AM
Member
Thread Starter
Join Date: Nov 2012
Location: USA
Posts: 3,262
So if I remove the wet end and reinstall the pump and crank the motor with the rope I hold see them move .
Geo
 
  #4  
Old 06-26-14, 07:09 AM
Member
Thread Starter
Join Date: Nov 2012
Location: USA
Posts: 3,262
Need advice on how to adjust the unloader valve on Annovi Reverberi pump.
Geo
 
  #5  
Old 06-26-14, 06:13 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,818
I usually just start about halfway and fine tune one way or the other depending on if it's chugging too hard before it unloads when I release the handle. If so, lighten up on the spring tension a little.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes