Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

i have a scag tiger cub with a 19 hp kawasaki motor, problem is wont charge


nelmister's Avatar
Member

Join Date: Jul 2014
Posts: 6
IN

07-21-14, 03:35 PM   #1  
i have a scag tiger cub with a 19 hp kawasaki motor, problem is wont charge

new battery, new voltage/regulator . when i put in a new 20amp fuse it blows ,it mustbe a short but where do i start?

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

07-21-14, 11:45 PM   #2  
Disconnect the negative cable from the battery, then connect a test light from the cable to the battery. Make sure the key is turned off. Put a new fuse in. The test light will light up now if there is a short. Unplug various things until you find what turns the light off. This helps narrow down the culprit. Post back with results and we'll go from there if necessary.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
nelmister's Avatar
Member

Join Date: Jul 2014
Posts: 6
IN

07-22-14, 12:43 PM   #3  
thanks i will let you know what happens.

 
nelmister's Avatar
Member

Join Date: Jul 2014
Posts: 6
IN

07-22-14, 05:43 PM   #4  
I did exactlyas instructed, removed neg battery cable clipped on tester on cable end and other end of tester to neg post of battery,key off and new fuse in. tester does work but not lit at this time,could it be the key switch?

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

07-22-14, 10:38 PM   #5  
But if you connect the battery cable it blows the fuse? Or do you have to turn the key on before it blows? If it happens when you turn the key on, then leave the test light connected as I described, unplug the fuel shutoff solenoid on the carburetor so that it isn't drawing power, and then proceed to find out what turns the light off.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
nelmister's Avatar
Member

Join Date: Jul 2014
Posts: 6
IN

07-24-14, 04:22 PM   #6  
I found the short ,it was under the rotor.One of the wires going to the charging coil was shorting out,strip it back crimped it back on copper wire.put back together no short and charging at 14volts.life is good. Thanks so much for your help.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

07-24-14, 06:41 PM   #7  
Glad you found it, thanks for the update.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread