Troy Built Pressure Washer Won't Start at all, Bad Switch???

Reply

  #1  
Old 08-08-14, 09:09 PM
Member
Thread Starter
Join Date: Aug 2014
Posts: 2
Troy Built Pressure Washer Won't Start at all, Bad Switch???

I purchased a twice-used Troy-Built 3000 PSI Pressure Washer from a neighbor who was moving. I saw the tool work previously. It has the Honda GVC 190 motor. New fuel, good oil, new spark plug. Will not start. Does not even attempt to fire. Followed all directions; switch is "on:, fuel line is "open" choke is full open. Does not even try to start. Crank pulls smoothly and the pressure is relieved from the spray handle. The one thing I notice is the motor reacts the same whether the switch is in the "on" position or the "off". Could it be a bad switch????

Any help is appreciated.
 
Sponsored Links
  #2  
Old 08-10-14, 05:46 PM
Member
Join Date: Nov 2012
Location: USA
Posts: 2,973
Have you checked for a good spark?remove the plug install the plug wire and ground the plug to the engine block and try to start and see if there is a good spark.
Also is the plug wet or dry when you remove it?
Geo
 
  #3  
Old 08-11-14, 08:44 PM
Member
Thread Starter
Join Date: Aug 2014
Posts: 2
Thanks for the reply. I have tested both. The plug is dry when I remove it and we tried testing the plug against the block and no spark.
 
  #4  
Old 08-11-14, 09:17 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,575
Unplug the kill wire from the coil and check for spark again.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 05:57 PM.