New carb, old problem


  #1  
Old 09-18-14, 01:11 PM
S
Member
Thread Starter
Join Date: Sep 2014
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
New carb, old problem

Tecumseh 10 hp engine HMSK100 - 159208T on a 20-year-old MTD snowblower. The engine would only run at full choke, full throttle.

The thing was a gift, but I decided to rebuild it and try it this winter. I installed new carb, spark plug, fuel lines, cleaned and lubricated, etc.

Starts with half a pull... but still stalls out when I open the choke even halfway.

My guess would be the idle air adjustment, but I welcome any guidance. Thanks.

BTW, why is there no air cleaner - or even any provision for an air cleaner - on this engine???
 
  #2  
Old 09-18-14, 01:18 PM
G
Member
Join Date: Jun 2006
Location: United States
Posts: 2,296
Upvotes: 0
Received 31 Upvotes on 29 Posts
First, most snowblowers don't have air cleaners they freeze up. Second, with the engine running dribble/spray some carb/brake parts cleaner behind the carb along the mating surfaces of the intake, if the engine tempo changes you have an air leak and can take the appropriate action. Have a good one. Geo
 
  #3  
Old 09-19-14, 08:45 AM
S
Member
Thread Starter
Join Date: Sep 2014
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Thanks. The carb was a bit loose and that made a slight difference, but I had to open the air idle screw a full turn before the engine would run with the choke open. Now it idles at any throttle setting.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: