Pressure washer shutting off after 10-15 minutes

Reply

  #1  
Old 09-25-14, 05:00 PM
Member
Thread Starter
Join Date: Sep 2014
Location: usa
Posts: 1
Pressure washer shutting off after 10-15 minutes

Ok, I've been at it all day. Let me tell you what it's doing and what I've tried. The washer starts fine, pressure is fine but about 10 minutes in it shuts off. I will restart it then it works for 5 minutes then 2 then 1...ect.

The pressure washer is a generac 207 bar 3000psi and does have a low oil turn off switch.

I have done the following:

New gas in tank
Flow from tank
Oil change
Cleaned air filter
New spark plug
Loose gas cap for airflow
Checked lines to carb from tank
Cleaned carb

The only thing I can think of is it overheating then shutting off OR the low pressure oil switch could be malfunctioning. Has anyone had a similar problem or know what I should do? I can't find the switch to save my life but I know its on there somewhere.

Thank you.
-Frustrated
 
Sponsored Links
  #2  
Old 09-25-14, 09:01 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,818
Does it ever shut down for good and not restart? If so, check for spark when it won't run. If not, it sounds much like a fuel problem, like the flow into the bowl is insufficient.
 
  #3  
Old 10-08-15, 11:36 AM
Member
Join Date: Oct 2015
Location: Usa
Posts: 1
Pressure washer shutting down after 10 minutes

Try disconnecting the wire to the oil pressure switch. I had the same problem and if I disconnected that wire. It ran perfectly. I changed my oil filter and was able to reconnect the pressure switch.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes