Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Poulan Pro riding mower deck problems


steve_c's Avatar
Member

Join Date: Oct 2014
Posts: 1
NC

10-06-14, 12:03 PM   #1  
Poulan Pro riding mower deck problems

I have a Poulan Pro riding mower (Model # PP 125H38LMA) - 38" deck, 2 blades. I'm the original owner & have never had to adjust the deck since I bought it. I used it a couple weeks ago without an issue. However, using it yesterday, I did have an issue.

I keep the deck set at 5 & have not had any problems with it. If I set it lower, it will hit exposed tree roots in our yard. Set at 5, it glides over them without issue. Yesterday, I mowed the yard & noticed that it seemed to clip virtually every root that I had previously been able to mow over. While I was mowing, I thought the grass seemed to be a little short, but not too bad. It did kick up a lot of dust, which wasn't altogether unusual, but in hindsight, was abnormally high.

When I was mowing another section of the yard (no roots), I mowed on an incline, and noticed when I looked back that the right hand side (the downhill side) the area under that blade was skinned. All the way down to the ground, there was no grass. However, it was only under that blade (the other one appeared to be fine).

I haven't leveled the deck (ever), but given that this change was so immediate, I thought something might have broken on the deck (the time before this, it mowed without any of the issues today). In checking yesterday, I didn't see anything obviously broken, nor did the deck look like it was sagging on either side.

I haven't hit anything (other than the tops of the roots yesterday) with it, and it's mowed this yard countless times without any problem. Is it typical of a mower deck to go out of adjustment/level so quickly? Is there something else to check? Please advise.

The mower itself is a Poulan Pro 125H38LMA - 12.5 hp Briggs engine, 38" mulching deck. Product # is 954-00-54-11. I believe it was purchased in the mid 90's. I have been unable to find a manual for it.

Thanks!!

 
Sponsored Links
chandler's Avatar
Banned. Rule And/Or Policy Violation

Join Date: Dec 2005
Posts: 39,968
GA

10-06-14, 01:19 PM   #2  
Welcome to the forums! Have you looked on top of the deck to see if a pin as become dislodged? Have you checked your tire pressure on all tires, especially on the low side.

 
Search this Thread