ditch witch

Reply

  #1  
Old 12-03-14, 03:07 PM
Member
Thread Starter
Join Date: Dec 2014
Posts: 2
ditch witch

I have a ditch witch 255 sx with a Honda motor it runs fine at a idol but if you try to move it loses power. any ideals?
 
Sponsored Links
  #2  
Old 12-03-14, 03:09 PM
chandler's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Dec 2005
Location: USA
Posts: 39,968
Welcome to the forums! Do you have the idle set to high? It takes a lot to run the mechanics of the unit, so a high motor RPM is necessary. Can you engage the bar or move the bar?
 
  #3  
Old 12-03-14, 03:12 PM
Member
Thread Starter
Join Date: Dec 2014
Posts: 2
Idol is fine. It ran fine during the summer now that it's cold is when it started
 
  #4  
Old 12-03-14, 05:21 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,813
Sounds like a carburetor issue if it won't rev up.
 
  #5  
Old 12-03-14, 05:39 PM
Norm201's Avatar
Member
Join Date: Sep 2013
Location: USA
Posts: 5,956
This is only a guess. Is the carburetor housed? If not it may need a cover for the engine heat to keep it warm and not freeze up. My snow blower says to remove housing if normally used in temps above 40 degrees.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes